1. Asus G74sx-a1 Drivers For Mac
  2. Asus G74sx-a1 Drivers For Macbook Pro
  3. Asus Rog G74sx Drivers
Asus g74s drivers download

Asus G74sx-a1 Drivers For Mac

I've run into an odd problem when trying to clean install Windows 10 64-Bit on my ASUS G73JH-A1 using a USB 2.0 Flash Drive and hopefully someone can point me in the right direction. I can boot the G73JH-A1 from my USB 2.0 Flash Drive that was created by the Media Creation tool located at: When setup starts I can get past where you select your language and keyboard type but then I run into an error that says: A media driver your computer needs is missing. This could be a DVD, USB or Hard Disk driver. If you have a CD, DVD or USB flash drive with the driver on it Please insert it now. Note: if the installation media is in the windows DVD drive or on a USB drive, you can safely remove it from this step. Any idea how to get around this?

Asus G74sx-a1 Drivers For Macbook Pro

I was reading some other posts about this issue that other people are having on other computers and one solution was to use the 32-Bit version instead but I want to use the 64-Bit version. I've also read other posts saying that my download may be corrupted. So I've recreated my USB Flash Drive several times now to include both 32-Bit and 64-Bit even on a different computer. Same issue so a corrupt download is not the issue. I've tried using the 32-Bit selection and it works and does not report any missing drivers however the 64-Bit one behaves the same reporting missing drivers every time.

Asus Rog G74sx Drivers

Asus G74sx-a1 Drivers For Mac

What driver is missing in the 64-Bit that is present in the 32-Bit? Just for some background info, I was running Windows 8.1 on my G73JH-A1 and upgraded to Windows 10. It upgraded just fine and activated.


I am not having any problems per say however I would feel a whole lot better running a clean install over and above an upgrade. When I clean installed Windows 8.1 x64 on my G73JH-A1 using my USB Flash Drive, I never ran into any issues. Any help for this issue clean installing Windows 10 using my USB Flash Drive would be greatly appreciated.