I have an external Pioneer DVD-RW DVR-116d burner hooked to my Duo iMac and since I updated the software with software update, Leopard only recognizes it as a Mass Storage Device. Says it's manufacturer is Prolific Technology Inc.

So it doesn't recognize any DVD or CD that I put in it, blank or not. I've tried putting it on different USB ports and Firewire even with no success. I was about to reinstall my entire system just to get things back to where they were before, but those same updates solved a different problem I'd been having. The built-in drive is unreliable after using a game disk that had too much art on it or something, making the drive make noises.


Since then the internal just hasn't been the same, hence I purchased the Pioneer external from OWC. Any ideas from you folks would be much appreciated. You may need a Guru or Gear-Head, but here are some suggestions/thoughts: 1.

Post Your Full Specs: Mac Model, Processor, RAM, OS, HD, favorite Etruscan Erotic Word-Problems, et cetera. Have you contacted? If the bottom line is that the thing is not yet supported,depending on your machine-and if you have an external drive or a partition program-you can create a partition dedicated to the earlier OS that will recognize the DVD burner. Granted, this is a pain in that you have to boot into that every time you want to use it, but it could be a 'quick 'n dirty' work-around.

Use Disk Utility. Select the first of the names given to your Pioneer Drive listed in the L pane of DU, and then click the Info button on the top bar of the DU window. This should give you a full rundown of the optical drive's specs.

Pioneer Dvd Rw Dvr 116d Drivers For Mac

Pioneer Dvd-rw Dvr-116d Drivers For Mac

Id card software for mac. Prolific Technology probably refers to the controlling chip in the Pioneer's enclosure, and that may be the problem, ie. The chip is not compatible with the latest Leopard. Have you checked the Pioneer website for any information regarding the 116D and Leopard? Pioneer usually works right out of the box with Macs, incl Leopard OS. You've answered my silent question about means of connection, ie.

USB or firewire. Since you've tried both, it cannot be a power supply issue, but try swapping cable ends, a different cable, and power the optical drive on BEFORE connecting it to your Mac.